Lancom All-IP VoIP DNS Konfiguration

Durch die Kündigung der ISDN-Anschlüsse seitens der Telekom, hatte ich eine nicht unerhebliche Anzahl von Umstellungen in Richtung All-IP, von bestehenden Telefonanlagen über einen Lancom Router. Zum Einsatz kam hier fast immer der Lancom 1781VA mit der Lancom All-IP Option.

Durch den sehr guten Wizard im LANconfig Tool, geht die Konfiguration auch ohne Probleme. Im Rahmen meiner Umstellungen stand ich aber mehrfach vor dem Problem, dass der VoIP Call Manager keine Registrierung bei der Telekom durchführen konnte, und der Grund dafür waren immer fehlende DNS-Einträge am Lancom Router.

Das ist an sich kein Problem, wenn bekannt ist, wo diese Einträge zu setzen sind. Was ich später erkläre.

Meine ursprüngliche Annahme war nämlich, dass der VoIP Call Manager seine DNS Abfragen einfach gegen den von der Telekom zugewiesene DNS-Server richtet. Die beiden DNS-Server habe ich im Bild unten grün markiert.

image

Was er aber nicht tut … und damit schlägt die Registrierung fehl! (Sorry wegen des schlechten Fotos … das ist nicht von mir Winking smile )

image

Eine Lösung für das Problem ist die Verwendung von öffentlichen DNS-Servern, welche im Lancom Router wie folgt eingetragen werden müssen.

Configuration / IPv4 / Addresses / Name server addresses

image

Ich habe hier die beiden öffentlichen DNS-Server von Google verwendet, also 8.8.8.8 und 8.8.4.4.

Danach funktionierte die Registrierung und Auflösung von tel.t-online.de ohne Probleme und die Telefonie ebenfalls.

Enjoy it, b!

3 Gedanken zu „Lancom All-IP VoIP DNS Konfiguration

  1. Hallo, das scheint aber nicht richtig zu sein. Dort werden die DNS Server eingetragen welche für die Remote-Einwahl von, z.B., VPN-RAS verwendet werden.
    Die richtige Einstellung ist unter Konfiguration>Kommunikation>Protokolle>IP-Parameter vorzunehmen.

    Viele Grüße

    • Hallo Sebastian
      Das scheint mir so nicht richtig zu sein. Unter Konfiguration>Kommunikation>Protokolle>IP-Parameter bzw. Configuration>Communication>Protocols>IP parameters … erscheint bei mir der folgende Hinweis:

      „If certain remote sites do not automatically transmit the IP parameter needed for connection, then enter these values here.“

      Ich habe darauf hin nochmals zwei Router überprüft und beide funktionieren mit den von mir im Blog beschriebenen Einträgen. Lancom hat das nicht optimal gelöst, dass „Address pool for in-dialing access“ und „Name server addresses“ im gleichen Feld liegen.

      Dazu schlägt die Registrierung wieder fehl, wenn ich dort die beiden DNS raus nehme.

      Grüße, b!

      • Hi, b!
        ich habe das bei meinem 1906VA so eingestellt wie eingangs von mir geschildert.
        Die Adressen die beim Dial-In stehen werden an die VPN Clients weitergegeben, ändere ich dort etwas – ändert es sich auch im Client.

        Den Eintrag oben bei den IP-Parametern habe ich gesetzt, auch dort greift es..

        Eieiei .. das ist aber auch verwirrend.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s