SBE 2011 und Windows 10 Clientbackup (1% Problem mit UEFI)

In einem früheren Blog hatte ich das Problem mit dem Backup von Windows 10 Clients und dem Windows Small Business Server 2011 festgestellt dafür aber keine Lösung gesucht:

https://sbsland.wordpress.com/2014/10/12/windows-10-tr-preview-und-der-sbs-connector/

Damals hatte ich das Problem auf eine Inkompatibilität des Windows 10 TP mit dem SBS Connector zurückgeführt. Die Ursache war aber ein fehlender Patch für den SBE 2011 damit auch Computer mit UEFI gesichert werden können. Der Hotfix ist unter folgendem Link verfügbar:

https://support.microsoft.com/en-us/kb/2781270

Nachdem der Hotfix installiert, und der Server neu gestartet wurde muss unbedingt nochmals Windows Update bemüht werden – damit das folgende Update ebenfalls installiert wird:

https://support.microsoft.com/en-us/kb/2934953 

Wichtig: Ohne dieses zweite Update funktioniert das Backup von Clients mit UEFI-Boot nicht, das Launchpad bzw. das Dashboard des SBE 2011 beglückt einen dazu mit obskuren Fehlermeldungen. Insgesamt sind damit zwei Neustarts notwendig.

Das Problem zeit sich übrigens darin, dass ein Backup gestartet werden kann es jedoch bei 1% stehen bleibt und danach abbricht.

image

Ich habe bis vor kurzem keinen “echten” Computer mit UEFI-Boot gehabt, dann wäre nämlich das Problem auch schon mit Windows 8.x aufgetreten.

Das gleiche Problem hat übrigens auch der Windows Home Server 2011 welcher auf der gleichen Basis entwickelt wurde wie der SBE 2011. Allerdings muss für diesen einen anderen Hotfix verwenden:

https://support.microsoft.com/en-us/kb/2781272

Genauso wie beim SBE 2011 darf danach folgender Hotfix nicht fehlen:

https://support.microsoft.com/en-us/kb/2934953 

Eine gute Übersicht, welche Maßnahmen für verschiedene Small Business Server Connectoren notwendig sind, damit eine Sicherung mit UEFI-Computer erfolgen kann ist in folgendem Blog vorhanden:

http://blogs.technet.com/b/sbs/archive/2015/07/23/client-connector-availability-with-windows-home-server-small-business-server-and-windows-server-essentials-for-supported-client-os.aspx

Das der Hotfix nicht über Windows Update angeboten wird, verstehe ich nicht. UEFI ist ja nun wirklich nicht mehr neu und die Suche nach dem Problem mit den abgebrochenen Backups bei 1% nicht gerade trivial.

Ob die Installation auch geklappt hat lässt sich wie folgt überprüfen:

dism /online /get-Packages |findstr /i "2781270"

Microsoft bezeichnet diesen Hotfix übrigens als Feature Pack, was es ja auch irgendwie ist.

image

Alle Clients bekommen das Update für ihren Connector automatisch vom Server, müssen danach aber neu gestartet werden.

Enjoy it, b!

6 Gedanken zu „SBE 2011 und Windows 10 Clientbackup (1% Problem mit UEFI)

  1. Lieben Dank an den Author. Allerdings besteht das Problem auf einem aktuell gepatchten SBS 2011 Standard heute (Anfang März 2019) wohl immer noch. Der Patch unter diesem Link genannte Patch ist nicht mehr verfügbar: https://support.microsoft.com/en-us/kb/2781270. Warum wurde dieser durch Microsoft zurück genommen? Wir können dadurch einen Rechner des Kunden nicht sichern. Gibt es vielleicht noch eine andere Lösung?

  2. Wie sieht es mit der Idee aus, sich einfach an den Microsoft Support zu wenden? Ich habe leider keinen SBE 2011 mehr im Betrieb um die Schritte, etc. zu probieren.
    Selbst habe ich immer gute Erfahrungen mit dem Support gemacht.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s