Fix: Windows 10 Update 21H2 und der Essentials Connector

Info: Bitte die Update Historie unten lesen, ursprünglich wurde das Script für Windows 10 Version 1903 entwickelt und seitdem immer wieder getestet und aktualisiert. Für alle die nicht lesen wollen, die aktuelle Version des Scripts befindet sich hier .

For the english version, please follow this Link.

Zumindest aus Sicht des Windows Server Essentials Connector ist jedes Update von Windows 10 spannend. Die seit gestern offiziell verfügbaren Version 1903 für Windows 10 versäumt es beim Upgrade, die für die Ausführung des Windows Server Essentials Connectors notwendigen Dienste (Services) zu migrieren. Die sind nach dem Update nicht mehr vorhanden.WSE-1903

Damit ist der Windows 10 Client nicht mehr in der Lage sich am Windows Server Essentials an zu melden um seinen Status zu kommunizieren oder eine Sicherung durch zu führen. Im Dashboard des Server erscheint der Client Offline.

image

Damit das wieder klappt, müssen die Services hergestellt werden. Das geht am einfachsten durch das folgende Script, welches die Services in Form von REG-Dateien in die Registry importiert. Im Anschluss, nach einem Neustart funktioniert der Connector ohne Probleme.

image

Das Script und die dazu notwendigen REG-Dateien sind in der ZIP Datei als Download verfügbar. Für eventuelle Schäden lehne ich jegliche Haftung ab.

  • Die Ausführung des Scripts muss in einer PowerShell-Session als Administrator erfolgen
  • Script und REG-Dateien müssen zwingend im gleichen Verzeichnis liegen
  • Das Script prüft ob es sich um den Version 1903 oder höher handelt. Nur dann werden die REG-Dateien in die lokale Registry des Windows 10 Clients eingetragen

Möglicher Weise können Probleme mit der PowerShell Execution-Policy auftreten, dazu wende ich den folgenden Workaround an.

Get-Content -Path .\Fix-WSeLaunchpad-1903.ps1 | PowerShell.exe -NoProfile -

image

Update 30.05.2019:

Inzwischen ist es mir gelungen, dass Microsoft dieses Problem als Bug (Fehler) betrachtet und an einem Fix arbeitet. Wie schnell damit zu rechnen ist, kann ich nicht sagen melde mich aber wenn ich weiteres weiß.

Update 15.07.2019


Das Script, und damit der Workaround funktionieren mit dem WSE 2016 und dem WSE 2012R2, dass mag im Blog nicht richtig rüber gekommen sein. Für die anderen Versionen (WSE 2011 und 2012) müsste man die Registry-Einträge des Connectors vergleichen.

Update 21.07.2019


Ich hatte nun die Gelegenheit Windows 10 Clients an einem SBE 2012 (ohne R2) um zu stellen und muss gestehen, dass das Script hier definitiv nicht funktioniert. Der Clientconnector dort verwendet wohl andere Einträge in der Registry als unter Windows Server 2012R2/2016.

Update 18.11.2019


Mit dem Update auf Windows 10 1909 gibt es keine Probleme, dass liegt an der von Microsoft geänderten Bereitstellung. Dazu werden vornehmlich nur Features freigeschaltet, die schon in früheren Versionen vorhanden waren.

Update 11.12.2019


Wird ein ISO mit Windows 10 1909 für einen Upgrade, zum Beispiel von Windows 7 auf Windows 10 verwendet. Schlägt der Bug wieder zu und das bisherige Script funktioniert leider nicht. Darum habe ich eine kleine Änderung durchgeführt und eine Version erstellt (steht nun auch in der History), die mit 1903 und neuer funktioniert.

Update 15.05.2020

Auch mit Windows 10 2004 tritt dieses Problem auf und kann über das Script behoben werden. Ich habe an diesem eine Reihe kleinerer Korrekturen durchgeführt und hier zum Download bereitgestellt.

Update 23.10.2020

Seit dem letzten Jahr, oder denken wir in Updates, seit Windows 10 Version 1909, liefert Microsoft das Herbstupdate als normales Windows Update aus, dass Features die im Verlauf der letzten Monate durch Updates (in 2004) installiert wurden aktiviert. Damit funktioniert das Update auf diesem Weg ohne Probleme und das Script ist nicht notwendig. Erfolgt aber ein Upgrade, zum Beispiel der Version 1909, durch das Windows 10 20H2 ISO, kann das Script im Anschluss den Connector reparieren.

Update 05.06.2021

Mit dem Windows 10 21H1 Update funktioniert das Script in der aktuellen Version ohne Änderungen. Wird das Update über den WSUS oder Windows Update installiert, dann funktioniert der Windows Essentials Connector ohne Probleme und das Script ist nicht notwendig. Erfolgt das Update hingegen über eine ISO Datei, die es als Download bei Microsoft gibt, kann der Essential Connector im Anschuss über das Script repariert werden.

Enjoy it, b!

103 Gedanken zu „Fix: Windows 10 Update 21H2 und der Essentials Connector

  1. Hi Bernd,
    Did not work for me.
    After upgraded from W10 1803 to 1903, client’s connector starts but cannot connect to server, and the client is off-line on dashboard.
    Initially server said there is no trust. Then I removed client from domain, joined workgroup, then rejoined domain. Trust restored, but still „off-line“.
    Your script did not help, maybe cose not right time applied…
    Now I’m at the point where I can not uninstall the connector – uninstall path not found.
    Best regards,
    Remigijus

    • Basically you can revert your Windows installation to the build used before. So going back to 1809 and restart with upgrade and the fix would be my choice for troubleshooting.
      Keep your fingers crossed, b!

  2. Viele Dank für deine Hilfe , dein Scipt hat bei mir einwandfrei funktioniert. Ich musste die Dienste nur von manueller Start auf automatisch stellen. Super Arbeit

  3. Jetzt muss ich mal kurz fragen da ich nicht ganz so bewandert bin mit diesen Scripten.
    Muss ich das Script nur auf dem Server ausführen oder auf jedem Client PC einzeln ?

    MFG Mark

    • Mit dem WSE2012 konnte ich das nicht testen. Du kannst aber an einem funktionierendem System mit dem WSE2012 Connector die Registry-Keys vergleichen …
      /b!

  4. THX for the great hint. I’m using a Windows Home Server 2011, after the 1903 update I got similar problems. With the help from this side I was able to identify the affected windows services. I exported the reg branches from a working 1803 system. After the restore on an 1903 system this system is working as expected.

    Here the registry-branches for a WHS2011 (alle unter HKLM\System\CurrentControllSet\Services\)
    – HealthAlertSvc
    – initMonitor
    – LANConfig
    – NotificationsProviderSvc
    – providers_system
    – ServiceProviderRegistry
    – SqmProviderSvc
    – WSS_ComputerBackupProviderSvc

    Just export them to a USB-stick and use a doubleclick for each file on the updated client, or use this ZIP instead.

    http://pascor.de/down/1903_whs2011.zip

    Grüße Markus

    • Thanks Markus for supporting this problem. While WHS2011 uses the same connector like SBE2011, this should work. Both products (including Windows Storage Server 2008R2) where from the „Colorado“ project, and as far as I know, sharing the same code base for the storage / essential stuff.
      Enjoy it, b!

      p.s. Any plans for a life beyont WHS? That’s interesting for me while Microsoft shutdown it’s small business server line.

      • Hey, actually I’ve no special plans. The main reason for using a server system at home is to have a file server for files and backups.
        Therefor I’m working on a blueprint for a Win10 Pro system. I’ve some hardware parts and lics lying around here. I think this is a reliabile way, and will fullfill my needs. I’ll use a software raid system (raid 1 I think), and a additional big disk for backups of the „server“ itself.
        I’m not a fan of these prop. NAS-Solutions, in a case of failure you’ll get problems to get back your datas.

        Markus

      • Yes, I understood. From a technical perspective a Synology, QNAP or whatever RAID is similar like attaching several disks to a Broadcom/Avago RAID controller with the hope/trust the controller will handle data properly. I’m testing a Synology-RAID for home purposes and it’s running very well, but backup (disk and Azure) is needed further I made a decission to replace the NAS every 4 years.
        I know it’s not easy to find an answer for SBE replacement …
        /b!

    • Markus, I have tried the above zip download but your link no longer works.
      Your reg tweaks worked for me before, but I stupidly did not keep them!

    • I have a Windows Home Server 2011.
      But the Link above for WHS2011 does not now work.
      Would you please send me a new link to the WHS2011 links.

      • Hello John
        The code for 2011 has never been hosted by myself. There was a link to a third site, but I haven’t stored the code.
        Cheers, Bernd

      • I deleted the registry tweaks for clients of my WHS2011 and replaced them with your 21H2 links, not realising they were only for Windows Server Essentials, until my Health Service monitoring failed 😨

        Would you consider giving my email address to the contributor (Markus) and asking if he would get in touch with me please?

        John

        >

  5. Das script funktioniert auf den clients, die Dienste werden entsprechend gelistet, stehen aber auf Deaktiviert und können nicht gestartet werden. Die Connectorsoftware konnte deinstalliert und nach Neustart wieder soweit installiert werden, bis die Abfrage nach den Anmeldedaten kommt. Dort bricht die Installation immer ab mit der Meldung, dass der Server nicht erreicht werden kann. Eine Remoteverbindung zur gleichen Zeit von der gleichen Maschine zum Server (WSE2016) funktioniert. Auch ein Virenscanner (Kaspersky) auf dem Client ist deaktiviert. Was könnte das Update 1903 noch verbogen haben?

    • Genau dieses Problem hatte ich auf insgesamt 2 Clients von über 50 … bin hier aber noch nicht weiter gekommen. Möglicherweise läuft eine Anfrage ins Leere. Kann die Sache aber erst nach meinem Urlaub weiter verfolgen.
      /b!

  6. I just want to say thanks. After upgraded my Windows 10 systems to 1903, all of them stopped connecting to my Windows Server 2016 with Essentials Connectors. Your script was a great help to restore the backup functionality. Much appreciated.

  7. Pingback: Windows 10 May 2019 Update – ー4℃

  8. Another heartfelt thank you for this script. I have a Windows 10 tablet that has only just installed 1903 and after much head-scratching, attempted reinstallation and digging through Microsoft ‚Answers‘ entries the mention of this page has saved me a lot of further heartache. This is the second time that MS have managed to make WSE12 clients totally useless after a Windows update (although the restore problems might only have affected Windows 7 clients, I don’t remember) and sometimes I wonder why I fight this stuff. Of course, MS don’t seem interested in the low end market any more, so I may not be fighting with this particular flavour for much longer.

    • Hello Shawn
      Today I’m waiting for 1909 to do my first tests. While Microsoft has changed the nature about 1909 will come to your PC (it’s more an Update than an Upgrade) as a cumulative update I don’t believe that this will break the connector again.
      While the former fail was the absence of connector registry keys, this could be fixed with the script in any upcoming version. The script changes nothing on Windows itself, it simply adds missing connector keys….
      If I have more information, I’ll come back with a new or updated blog post.
      Cheers, b!

  9. Hallo
    Stand 2019-10-18 hilft bei 1903 und 2012R2 : Script, ipv6 auf dem Client temporär ausschalten, Client reboot, Server reboot. In unterschiedlichen Kombinationen. 😉
    Gruss
    Itchy

  10. Vielen Dank für Dein Script und Deine Hilfestellungen. Leider bin ich für meinen Teil noch nicht wirklich weiter – dabei will ich nur zwei neue Win 10 Pro 1903 Rechner mit einem WSE 2012 r2 verbinden. Connector vom Server geladen und ohne Fehlermeldung mit dem Server verbunden. Der Wizzard wurde aber anschließend nicht gestartet und ich habe auch kein Launchpad. Im Dashboard des Servers steht der Rechner komplett offline. Ich habe nirgendwo Fehlermeldungen und kann doch nicht auf den Server zugreifen… Ohne Erfolg waren: die Netzwerkarte in der Registry dauerhaft von privatem auf Dömanennetzwerk zu patchen / den connector von Microsoft herunterzuladen (keine Fehlermledung nach Start, aber es passiert auch nichts) / Dein Script laufen zu lassen ( hat einwandfrei funktioniert, aber ebenfalls nichts geändert) / ipv6 für die temporär ausgeschaltet (frei nach itchy…)/ Ich bin kein Profi, aber jetzt ziemlich frustriert. Rechner nochmal komplett neu installieren? Ich habe weder weitere Ideen noch finde ich im Netz weitere Möglichkeiten…
    Gruß, cadest

    • Hallo Cdh
      Den Fehler welchen Du hier beschreibst, hat nichts mit dem 1903 Build und dem Upgrade zu tun. Vor 4 Wochen habe ich 2 PCs mit 1903 neu installiert und ganz normal in die Domäne gehängt, inklusive Installation des Connectors. Auch die Sache mit IPv6 deaktivieren ist nur bei einem „schlechtem“ IPv6 Design notwendig (wenn man die FRITZ!box sowas machen lässt).

      Schau Dir mal die Logfiles in %programdata%\Microsoft\Windows Server\logs an, hier im speziellen das setupapi.dev.log und ClientDeploy.log

      Beste Grüße, b!

    • Hallo Harry
      Gestern habe ich eine Reihe von Clients auf Build 1909 gebracht und dabei keine Probleme festgestellt. Mit 1909 hat aber auch Microsoft den Weg geändert, wie ein Update erfolgt. Bisher war ja das immer ein Upgrade welches technisch eine Neuinstallation mit Move von Programmen und Profilen war. 1909 ist lediglich eines der vielen Updates die wir alle Monate bekommen.

      Enjoy it, b!

      • Bei mir ging das „Update“ von 1903 auf 1909 ebenfalls ohne Probleme. Hat schon jemand Erfahrung mit direktem „Upgrade“ oder „Update“ von 1809 auf 1909? Hätte noch eine Maschine, die steht aber an einem entfernten Standort (VPN) und da wird ich dann ein „menschliches“Backup“ hinbeordern. Es kommt ja meistens anders und noch öfter als man denkt 🙂

    • Jetzt der letzte Post für heute. Beim Upgrade von 1809 auf 1909 ist das Verhalten identisch wie zu 1903. Sprich, die Clients werden nur noch offline im Dashboard gelistet … .
      Um auf die schnelle mal zu testen, habe ich im Script die Variable zur Prüfung des Builds von 1903 auf 1909 geändert. Ansonsten geht er ja in die Verzeigung der Else-Bedingung nicht hinein.

      Ausgeführt, Neustart und bis jetzt alles bestens. Alles natürlich auf eigene Gefahr. Vielen Dank nochmals an den Scriptersteller für die tolle Arbeit.

    • Hallo Julian
      Ich muss den Artikel aktualisieren, was ich aber vor Mittwoch nicht schaffe. Damit das Script unter 1909 läuft und auch unter 1903, sollte es ausreichen die folgende Änderung zu machen.

      if ($Build -eq (Get-ItemProperty …

      auf

      if ($Build -le (Get-ItemProperty …

      Viel Erfolg, b!

  11. Herzlichen Dank! Habe Upgrade eines Windows 7 Client auf Windows 10 gemacht und micht gewundert, dass der Client nicht mehr im Dashboard beim Essentials Server 2016 erschien (bzw. Offline). Nach Anwendung des Skrips läuft alles! TOP!

  12. Vielen herzlichen Dank! Hat bei mir einwandfrei funktioniert und nochmals Danke für das aktualisierte V1909 Skript – lief ebenfalls problemlos.
    Sehr guter Artikel. Einwandfrei funktionierende Lösung. Besser geht’s kaum!
    Weiter so!!

  13. Das ist ein exzellenter Fix. Ich arbeite seit DOS 2.11a mit Microsoft und habe schon viel mit MS erlebt, aber dieses Problem hat mich lange beschäftigt und es ist echt unfassbar dass MS dafür noch immer keinen Fix anbietet, es müssen schließlich ja nur die Service wiederhergestellt werden. Vielen herzlichen Dank – You definitely saved my day !!!!

  14. Hi,
    ich habehier einen brandneuen Thinkpad mit Windows 10 1909 und einem Windows Server Essentials 2016. Der Connector arbeitet auch nicht mehr –> Gleiches Problem wie oben – nach Eingabe der Zugangsdaten kommt die Fehlermeldung, dass der Server nicht erreichbar ist.

    Auch nach intensivem Googlen bin ich hier auf noch keine Lösung gekommen.
    Die Zeit ist synchron, einen Registry-Hack habe ich probiert… -> Keine Idee – wenn hier jemand das Thema lösen konnte, freue ich mich über Feedback!

      • Hi b!,
        Wenn man den Rechner per Connector einbindet, fragt der Wizzard nach den Zugangsdaten des Nutzers der den Computer benutzen wird -> Für diesen werden dann lokal Profildaten/ Einstellungen und Rechte übernommen.
        Wenn man Nach Eingabe der Einstellungen auf Weiter geht, kommt besagte Fehlermeldung – siehe meinen nächsten Kommentar.
        Viele Grüße
        Matthias

  15. Hallo,
    ich habe das gleiche Problem mit Windows 10 1909 und Windows Server 2016 Essentials – Ursache ist die folgende:
    Executing „C:\Windows\system32\nslookup.exe“ SRVFS1
    [4772] 200511.164602.2568: ClientSetup: Standard Error: *** SRVFS1 wurde von SRVFS1.bsi.local nicht gefunden: Server failed.

    Er versucht den Servernamen per NSLOOKUP aufzulösen ohne den Domainsuffix -da er es aber nur mit Abfrage am DNS-Server macht, kann ich am Client keine Anpassungen vornehmen. Man müsste irgendwie den FQDN des Servers im Connector hinterlegen – hat jemand von Euch eine IDee wie man da vorgehen könnte?
    Viele Grüße
    Matthias

  16. Pingback: Windows 10 Version 2004 | Windows SBS and Essentials Blog

  17. HI Ich bekomme den folgenden Fehler

    PS C:\> Get-Content Windows\Temp\wsefix-1903v4\Fix-WSelaunchpad-1903.ps1 | PowerShell.exe -NoProfile –

    Fixing Windows Server Essentials Launchpad on Windows 10 version 1903 and later, Copyright sbsland.me 2020

    Windows 10 is running on version 1909, the minimum version is 1903 …
    Current Windows build number is 18363
    Adding missing Registry Keys …
    ERROR: Error opening the file. There may be a disk or file system error.
    ERROR: Error opening the file. There may be a disk or file system error.
    ERROR: Error opening the file. There may be a disk or file system error.
    ERROR: Error opening the file. There may be a disk or file system error.
    ERROR: Error opening the file. There may be a disk or file system error.
    Registry Keys have been added, please reboot your Computer.
    Please reboot your system.
    Script finished!
    PS C:\>

    Script und REG-Dateien sind im gleichen Verzeichnis.

    • Ich schätze mal, dass die REG-Dateien nicht im gleichen Verzeichnis liegen wie das PowerShell-Script. Nach dem Entpacken muss im Verzeichnis das PowerShell-Script selbst und dazu die REG-Dateien liegen.

  18. worked perfect for me!
    Client upgraded to Windows 10 2004 -> no backup possible, Client was offline in Dashboard
    executed your PS-Script -> successfully finished
    Server 2012 R2 Essentials backup started <- works <- saved his live
    really good job !!!
    thank you so much !!!

  19. Ich bekomme folgende Meldung:
    Windows 10 is running on version 2004, the minimum version is 1903 …
    Current Windows build number is 19041
    Adding missing Registry Keys …
    FEHLER: Fehler beim Zugriff auf die Registrierung (5x)
    Registry Keys have been added, please reboot your Computer.
    Please reboot your system.
    Script finished!

    Wie behebe ich dieses Problem?

    • Wahrscheinlich hast Du keine PowerShell-Session als Admin gestartet, dann wird das Script in einem Context ausgeführt dem die notwendigen Berechtigungen fehlen.
      Also PowerShell, rechte Maustaste und Ausführen als Admin wählen …

      hth, b!

  20. Hallo
    Vielen Dank für das Script. Nach dem Update auf Windows10 2004 war der Computer im Windows Server 2012R2 Essentials offline.
    Script gestartet, läuft wieder. Super

  21. Thank you so much! Just updated to Windows 10 2004 and noticed it could not longer connect to my 2012 R2 Essentials server! Your life saver!

  22. Thank you so much for this. It works and saved a lot of time.
    We also work temporary all from home, so physical access to the pc not needed (I guess it is for reinstalling the connector) 🙂

  23. Hi, I ran your script after an upgrade to Windows 10 2004. It worked fine other than the VPN doesn’t seem to remember the password and I don’t seem to be able to persuade it to do so by entering it in VPN settings, the adapter is set to remember credentials etc. Not the end of the world but boring enough to reconsider reinstalling the connector which would slightly defeat the point.
    Any ideas as to what else might have been broken by the feature upgrade?

    • Hello Francis
      The Upgrade since a couple of versions missing to migrate the essential connector settings from registry. I fell into this trap without any configured VPN settings.

      So if the script helps you to get the connector functional without VPN, maybe it enables you to uninstall and reinstall the connector to make VPN working.

      Personally I don’t think that Microsoft will spend here any efforts to fix this. Windows Server 2016 was the last SKU containing the essential role … so our goal for the next years will be to build something similar to this.

      Cheers, b!

      • Thank you. I think the VPN credentials issue maybe an unrelated ‘feature’ of the 2004 upgrade. Other VPN users seem to have been affected.
        Have you tried the Essentials loaded onto 2019 as others have done which reportly works? Although no support from Microsoft that wouldn’t be far from the current state!

  24. You are an absolute genius & a godsend ! I cannot begin to express my gratitude. I have spent over a week trying to resolve this issue and this resolved things in minutes. Couldn’t get the Powershell command to work but just ran each reg file in turn and the problems on all five w/s resolved. Many, many thanks.

  25. Hallo Bernd, danke für das Script und die Hilfe, die Du damit bereitstellst! Hat nach Upgrade auf 2004 auf allen betroffenen Clients einwandfrei funktioniert.
    Merci
    Ralf

    • Hello Jamie
      This should be possible with GPO and maybe slight modifications on the script. I heard from a guy, copied the script to c:\temp\wse-fix and fired the PowerShell stuff from a GPO.
      Maybe worth to test, cheers b!

    • Ich habe den Artikel darauf hin angepasst. Wir haben die gleiche Situation wie vor einem Jahr. Wenn der Client auf 2004 läuft, dann werden die neuen Features nur freigeschaltet und man muss hier nichts reparieren. Lediglich ein Upgrade von älteren Version macht den Einsatz des Scriptes wieder notwendig.

      Bis Januar 2027, dann ist der Windows Server 2016 aus der erweiterten Support Phase von Microsoft draußen und wir wissen hoffentlich wie unsere SMB-Umgebungen bis dahin aussehen.
      Persönlich wäre ich froh, wenn ich nur einen Kunden gesehen hätte die ohne lokalen Datenspeicher (Dateiserver) auskommen.

      We will see, b!

  26. Apologies for this being in English and not German…

    Just done a clean install of Windows 10 20H2 onto a Dell Inspiron laptop – fully updated.
    Trying to connect it to a small Windows Server Essentials 2016 server by http://server_name/connect – server has been fully updated.

    I use an account with admin credentials.

    The Windows Server Essentials Connector Configuration Wizard fails with the error message ‚ An unexpected error has occurred‘

    I couldn’t get the Powershell script to work (never really used Powershell before!)
    Double clicked each of the registry entries and all 5 appear to have been successful.

    Any other suggestions as to what to try to get my laptop connected to my WSE 2016 server?

    Thanks

    • Hello Tony
      The script is to fix issues by upgrading Windows to the next version. The connector works by doing a clean install … so you did a clean new installation of Windows 10 20H2, than the installation of the connector works without any problems and the script isn’t needed.
      Next spring when Microsoft releases Windows 10 21H1 and you will do an upgrade, the connector possibly breaks and the script comes into the game.
      Cheers, b!

    • Add the SBS as the preferred DNS manually on windows 10 clients and the connector magically does its job.

      Cant take credit for this. Found it on the WWW and forgot where, but it works for me.

      • That’s true in case the connecot can’t find the server. The script fixes the absense of important service keys after upgrading Windows 10.
        Cheers, b!

      • Adding DNS solves the problem about not finding the SBE Server.
        The script fixes the absence of important registry keys after Windows 10 Upgrade.

  27. I cannot get the connector to work from a clean install of Windows 10 20H2 – my WSE 2016 server has all the latest updates.

    Any other suggestions?

  28. Sensationell! Vielen Dank dafür! Hat problemlos funktioniert. Ich weiss gar nicht wie oft ich schon den Rechner sonst in der Vergangenheit aus der Domäne entfernt und wieder hinzugefügt habe, und wie viel Arbeit das immer war.
    Es ist irgendwie peinlich das MS inzwischen selbst nicht mehr die ausreichende Kontrolle über ihre eigenen Produkte hat.

    • Der SBE als Rolle wird nicht mehr gepflegt und ist auch in Windows Server 2019 nicht mehr vorhanden. Wahrscheinlich war die Anzahl der Support-Requests zu gering oder die Kunden deinstallieren (vor dem Update) und installieren danach den Connector.
      Schade das wir mit dem Support-Ende von Server 2016 auf dieses, nach meiner Meinung, sehr interessante Produkt verzichten und für kleine Kunden Alternativen finden müssen.

  29. Pingback: Fix: Windows 10 Update and Small Business Essentials Connector | Windows SBS and Essentials Blog

  30. Guten Abend,
    ich nutze noch einen WHS 2011 und seit dem Windsows Update 2004 bzw. dem Oktober-Update
    funktioniert bei mir die Connector-Software nicht mehr. Auch bei einem Versuch den Connector neu zu installieren wird der Server nicht mehr gefunden, obwohl ich ihn im Netzwerk finde und auch über den Remotedesktop ansprechen kann.
    Hilft hier dieses Script auch eventuell weiter ?

    • Hallo Bothi,
      leider nein. Die fehlenden Einträge unterscheiden sich.
      In den Kommentaren oben war einmal ein Link zu den Dateien von 2011, der funktioniert aber leider nicht mehr.

      /b!

      • Das Script ist nicht für den Connector des WHS 2011 bestimmt. Dafür sind andere Registrys notwendig.
        Generell sollte die Auflösung immer über den Server laufen, was zugegeben beim WHS oftmals nicht der Fall war. Das ändert aber nichts daran, dass dieses Script mit dem WHS 2011, SBE 2012 (ohne R2) und allen anderen Versionen älter als Windows Server 2012 R2 nicht funktioniert.

  31. Following a suggestion from another site I managed to fix this without the script. Windows 10 20H2 and Essentials 2012r2

    1. Log on to client as domain admin
    2. Uninstall the connector
    3. Disable and re-enable the network adapter (This was suggested as the fix)
    4. Re-install the connector using admin credentials

    I will keep the script handy for the next Windows update though! Can I use the German version of the script for English Windows? The English link is dead.

    • The script is neutral, and the same in every language. While the most of the time im blogging in German my systems are all with english language settings.
      Cheers, b!

  32. Mal eine Frage: Ich hatte zwar keine Probleme mit dem Connector (Glück gehabt´, außerdem nutze ich ihn nur wenig) – jedoch kämpfe ich seit einiger Zeit mit anderen Verbindungsproblemen: Auf meinem WHS 2011 läuft auch ein SQL-Server 2008, seit ca. November letzten Jahres funktioniert jedoch der Zugriff auf die Datenbanken nicht mehr. Soweit ich der Ereignisprotokollierung entnehmen kann, kommen die Anweisungen von den Clients (WIN7, WIN 10) am Server an und werden verarbeitet, die Clients bekommen die Rückmeldung aber nicht mehr. Ausschalten der Firewall hat zu keiner Veränderung geführt. Auch nach dem (sowieso fälligen) Umzug auf eine neue Maschine mit Neuinstallation hat sich nichts geändert. Ist der Fehler evtl. in der gleichen Ecke zu suchen oder wo könnte ich noch suchen? Betroffen ist auch eine postgres-Datenbank auf der gleichen Maschine mit identischem Fehlerbild. Lediglich der hMail-Server tut noch seinen Dienst.
    Grüße & Danke,
    Karl

    • Hallo Karl, da neben Windows 10 Clients auch Windows 7 davon betroffen ist, sehe ich ein Problem mit den Windows 10 Updates erst einmal nicht.
      Wenn Datenpakete / Antworten sowohl an verschiedene Betriebssysteme, als auch bei der Kommunikation mit einer Datenbank verloren gehen, dann stimmt irgendetwas im Netzwerk nicht. Das kann ich aber, von hier nicht so einfach diagnostizieren.
      Hätte ich dieses Problem, würde ich erst einmal die Firewalls der Clients anschauen (ich verwende immer die ins OS integrierte), Virenscanner (falls es sich hier um ein 3rd-Party Produkt handelt, was ich auch nicht nehme) und dann mal einen Netzwerktrace z.B. für den WSUS ziehen und zwar auf dem Server und auf dem PC.

      Beste Grüße, b!

  33. I have this issue with a Server 2012 (not R2) install but I don’t have all my clients are 20H2 or above so I don’t have a source to work out how to adapt the .reg files/script to suit. HAs anyone else done this and can help me fix my problem? AT the moment it appears my older clients show up in Devices and I can select them in User properties to allow non-admin users to be able to remote access via AA but clients added in the last couple of years are not reporting in teh devices page on the dashboard. All clients are greyed out and showing ‚offline‘. I’m hoping this script will fix my connector issues but I need some help to get it to work with Server 2012.

    Many thanks,

    MIchael

    • Between the connector delivered with Windows Server 2012 and the R2 release are some elemental changes, which I hadn’t discovered yet. So the current script will work only with Windows Server 2012 R2 and later releases.
      Cheers, b!

  34. Habe einen einfacheren Weg gefunden um den Connector zu reparieren. Da Hauptproblem scheint wirklich DNS zu sein. Man kann einfach den Connector neu installieren, muss allerdings vorher in der Netzwerkverbindung den Server als DNS-Server eintragen. 😎👍
    Ich hoffe das hilft euch.
    VG

    • Hallo Achim
      Danke für den Hinweis, ich habe bisher gar nicht daran gedacht das der SBE nicht als DNS eingetragen sein könnte!
      Bei mir ist der SBE immer als DNS eingetragen, zusätzlich habe ich auch IPv4 und falls IPv6 vorhanden ist auch dieses korrekt konfiguriert.
      Das Script behebt ja das Problem der fehlenden Services-Einträge in der Registry.
      Grüße, b!

  35. Hallo,
    kann mal wer schicken was ich genau in Powershell eingeben muss?
    Ich habe leider keine Ahnung von Powershell und habe auch dieses Problem.

    Vielen Dank im Voraus
    Gruß Lukas

    • Das Script aus dem Blog herunterladen, entpacken und eine PowerShell-Sitzung mit Adminrechten starten.
      In dieser dann den folgenden Aufruf ausführen:

      Get-Content -Path .\Fix-WSeLaunchpad-1903.ps1 | PowerShell.exe -NoProfile –

      Kurze Frage, wie betreibst Du einen SBE ohne Kenntnisse von Dingen wie PowerShell … ?

  36. Hi, the same problem appeared with 21H1. I ran the script and the client computer management and monitoring services were running after reboot. However, the connector still reported ‚offline‘ although VPN and file access worked. A further reboot and the management service did not start automatically.
    None of the other WSE services showed as running.
    Any way to distinguish whether this is a client problem unrelated to the feature update?

    • Hello Francis
      I did a couple of tests, an upgraded a Lenovo T440s from Windows 10 20H2 to 21H1 (with installed Essential Connector) by an ISO. After the upgrade the Windows Server Essential Services where missing and I was able to fix this, like with the last updates with the script.
      I did this test with six different computers again, and I was always able to succeed.
      Cheers, b!

      • Thank you. I was just about to uninstall and reinstall the connector when it started working. I had just rebooted the server to complete the install of the May cumulative update so perhaps there was a server side glitch as well to add a little excitement. However, it all works even remotely so all now good.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s